<!DOCTYPE html>
<html dir='ltr'>
<head>
<meta content='width=device-width, initial-scale=1' name='viewport'/>
<title>The Case Against the Dolphins being Aggressively Stupid in Free Agency and the Draft</title>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='#212121' name='theme-color'/>
<!-- Windows Phone -->
<meta content='#212121' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='http://www.dolphinstalk.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="DolphinsTalk.com - Atom" href="http://www.dolphinstalk.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="DolphinsTalk.com - RSS" href="http://www.dolphinstalk.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="DolphinsTalk.com - Atom" href="https://www.blogger.com/feeds/7717974526047248338/posts/default" />

<link rel="alternate" type="application/atom+xml" title="DolphinsTalk.com - Atom" href="http://www.dolphinstalk.com/feeds/4951045537399458814/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://2.bp.blogspot.com/-I51DYVrgIZ0/WpS3goSkwEI/AAAAAAAAGPA/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL/s1600/Dolphin-fan-sad.jpg' rel='image_src'/>
<meta content='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' property='og:url'/>
<meta content='The Case Against the Dolphins being Aggressively Stupid in Free Agency and the Draft' property='og:title'/>
<meta content='    Let me start this off by asking you, the reader a few questions – how many times now has the Dolphins been crowned winners of the offsea...' property='og:description'/>
<meta content='https://2.bp.blogspot.com/-I51DYVrgIZ0/WpS3goSkwEI/AAAAAAAAGPA/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL/w1200-h630-p-k-no-nu/Dolphin-fan-sad.jpg' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<style type='text/css'>@font-face{font-family:'Ubuntu';font-style:normal;font-weight:400;src:local('Ubuntu Regular'),local('Ubuntu-Regular'),url(//fonts.gstatic.com/s/ubuntu/v11/4iCs6KVjbNBYlgoKfw7z.ttf)format('truetype');}@font-face{font-family:'Ubuntu';font-style:normal;font-weight:500;src:local('Ubuntu Medium'),local('Ubuntu-Medium'),url(//fonts.gstatic.com/s/ubuntu/v11/4iCv6KVjbNBYlgoCjC3jsGyI.ttf)format('truetype');}@font-face{font-family:'Merriweather';font-style:normal;font-weight:400;src:local('Merriweather Regular'),local('Merriweather-Regular'),url(//fonts.gstatic.com/s/merriweather/v19/RFda8w1V0eDZheqfcyQ4EInF5uFdDttMLvmWuJdhhgs.ttf)format('truetype');}@font-face{font-family:'Merriweather';font-style:italic;font-weight:300;src:local('Merriweather Light Italic'),local('Merriweather-LightItalic'),url(//fonts.gstatic.com/s/merriweather/v19/EYh7Vl4ywhowqULgRdYwIH3uxQAI1Bvm-GxtFNy4yl0.ttf)format('truetype');}@font-face{font-family:'Ubuntu';font-style:normal;font-weight:700;src:local('Ubuntu Bold'),local('Ubuntu-Bold'),url(//fonts.gstatic.com/s/ubuntu/v11/4iCv6KVjbNBYlgoCxCvjsGyI.ttf)format('truetype');}@font-face{font-family:'Merriweather';font-style:italic;font-weight:400;src:local('Merriweather Italic'),local('Merriweather-Italic'),url(//fonts.gstatic.com/s/merriweather/v19/So5lHxHT37p2SS4-t60SlCtfYakCkPqOMDce0h_3gD8.ttf)format('truetype');}</style>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
body#layout .hidden,
body#layout .invisible {
display: inherit;
}
body#layout .centered-bottom {
position: relative;
}
body#layout .section.featured-post,
body#layout .section.main,
body#layout .section.vertical-ad-container {
float: left;
width: 55%;
}
body#layout .sidebar-container {
display: inline-block;
width: 39%;
}
body#layout .centered-bottom:after {
clear: both;
content: "";
display: table;
}
body#layout .hamburger-menu,
body#layout .search {
display: none;
}
--></style>
<script async='async' src='https://www.gstatic.com/external_hosted/clipboardjs/clipboard.min.js'></script>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=7717974526047248338&amp;zx=aad7c4f3-6aef-459a-8911-2a770bb43a71' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=7717974526047248338&amp;zx=aad7c4f3-6aef-459a-8911-2a770bb43a71' rel='stylesheet'/></noscript>
</head>
<body class='item-view version-1-3-0 variant-vegeclub_darkaqua'>
<a class='skip-navigation' href='#main' tabindex='0'>
Skip to main content
</a>
<div class='page'>
<div class='page_body'>
<style>
    .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-I51DYVrgIZ0\/WpS3goSkwEI\/AAAAAAAAGPA\/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL\/s1600\/Dolphin-fan-sad.jpg);}
    
@media (max-width: 200px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-I51DYVrgIZ0\/WpS3goSkwEI\/AAAAAAAAGPA\/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL\/w200\/Dolphin-fan-sad.jpg);}}
@media (max-width: 400px) and (min-width: 201px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-I51DYVrgIZ0\/WpS3goSkwEI\/AAAAAAAAGPA\/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL\/w400\/Dolphin-fan-sad.jpg);}}
@media (max-width: 800px) and (min-width: 401px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-I51DYVrgIZ0\/WpS3goSkwEI\/AAAAAAAAGPA\/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL\/w800\/Dolphin-fan-sad.jpg);}}
@media (max-width: 1200px) and (min-width: 801px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-I51DYVrgIZ0\/WpS3goSkwEI\/AAAAAAAAGPA\/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL\/w1200\/Dolphin-fan-sad.jpg);}}
/* Last tag covers anything over one higher than the previous max-size cap. */
@media (min-width: 1201px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-I51DYVrgIZ0\/WpS3goSkwEI\/AAAAAAAAGPA\/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL\/w1600\/Dolphin-fan-sad.jpg);}}
  </style>
<div class='bg-photo-container'>
<div class='bg-photo'></div>
</div>
<div class='centered'>
<header class='centered-top-container sticky' role='banner'>
<div class='centered-top'>
<a class='return_link' href='http://www.dolphinstalk.com/'>
<svg class='svg-icon-24 touch-icon back-button rtl-reversible-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</a>
<div class='blog-name'>
<div class='section' id='header' name='Header'><div class='widget Header' data-version='2' id='Header1'>
<div class='header-widget'>
<a class='header-image-wrapper' href='http://www.dolphinstalk.com/'>
<img alt='DolphinsTalk.com' data-original-height='346' data-original-width='1600' src='http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/s1600/1111111.jpg' srcset='http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w120/1111111.jpg 120w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w240/1111111.jpg 240w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w480/1111111.jpg 480w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w640/1111111.jpg 640w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w800/1111111.jpg 800w'/>
</a>
<div class='replaced'>
<h1>
<a href='http://www.dolphinstalk.com/'>
DolphinsTalk.com
</a>
</h1>
</div>
</div>
</div></div>
</div>
<div class='search'>
<button aria-label='Search' class='search-expand touch-icon-button'>
<div class='search-expand-text'>Search</div>
<svg class='svg-icon-24 touch-icon search-expand-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</button>
<div class='section' id='search_top' name='Search (Top)'><div class='widget BlogSearch' data-version='2' id='BlogSearch1'>
<h3 class='title'>
Search This Blog
</h3>
<div class='widget-content' role='search'>
<form action='http://www.dolphinstalk.com/search' target='_top'>
<div class='search-input'>
<input aria-label='Search this blog' autocomplete='off' name='q' placeholder='Search this blog' value=''/>
</div>
<label class='search-submit-container'>
<input type='submit'/>
<svg class='svg-icon-24 touch-icon search-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</label>
</form>
</div>
</div></div>
</div>
</div>
</header>
<div class='centered-bottom'>
<main class='main-container' id='main' role='main' tabindex='-1'>
<div class='featured-post section' id='featured_post' name='Featured Post'>
</div>
<div class='main section' id='page_body' name='Page Body'><div class='widget Blog' data-version='2' id='Blog1'>
<div class='blog-posts hfeed container'>
<article class='post-outer-container'>
<div class='post-outer'>
<div class='post-wrapper not-hero post-4951045537399458814 image'>
<div class='snippet-thumbnail-container'>
<div class='snippet-thumbnail post-thumb-4951045537399458814'></div>
</div>
<div class='slide'>
<div class='post'>
<script type='application/ld+json'>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html"
  },
  "headline": "The Case Against the Dolphins being Aggressively Stupid in Free Agency and the Draft","description": "Let me start this off by asking\nyou, the reader a few questions &#8211; how many times now has the Dolphins been\ncrowned winners of the offseason by making&#8230;","datePublished": "2018-02-26T21:19:00-05:00",
  "dateModified": "2018-02-26T21:19:30-05:00","image": {
    "@type": "ImageObject","url": "https://2.bp.blogspot.com/-I51DYVrgIZ0/WpS3goSkwEI/AAAAAAAAGPA/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL/w1200-h630-p-k-no-nu/Dolphin-fan-sad.jpg",
    "height": 630,
    "width": 1200},"publisher": {
    "@type": "Organization",
    "name": "Blogger",
    "logo": {
      "@type": "ImageObject",
      "url": "https://lh3.googleusercontent.com/ULB6iBuCeTVvSjjjU1A-O8e9ZpVba6uvyhtiWRti_rBAs9yMYOFBujxriJRZ-A=h60",
      "width": 206,
      "height": 60
    }
  },"author": {
    "@type": "Person",
    "name": "Robert Melendez"
  }
}</script>
<div class='post-title-container'>
<a name='4951045537399458814'></a>
<h3 class='post-title entry-title'>
The Case Against the Dolphins being Aggressively Stupid in Free Agency and the Draft
</h3>
</div>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-author vcard'>
<span class='post-author-label'>
Posted by
</span>
<span class='fn'>
<meta content='https://plus.google.com/109378655489950229987'/>
<a class='g-profile' href='https://plus.google.com/109378655489950229987' rel='author' title='author profile'>
<span>Robert Melendez</span>
</a>
</span>
</span>
<span class='byline post-timestamp'>
on
<meta content='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html'/>
<a class='timestamp-link' href='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2018-02-26T21:19:00-05:00' title='2018-02-26T21:19:00-05:00'>
February 26, 2018
</time>
</a>
</span>
</div>
</div>
<div class='post-share-buttons post-share-buttons-top'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-byline-4951045537399458814' class='sharing' data-title='The Case Against the Dolphins being Aggressively Stupid in Free Agency and the Draft'>
<button aria-controls='sharing-popup-Blog1-byline-4951045537399458814' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-4951045537399458814' role='button'>
<div class='flat-icon-button ripple'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_share_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-4951045537399458814' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=facebook' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=twitter' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=pinterest' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Share to Google+' class='sharing-platform-button sharing-element-googlePlus' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=googleplus' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Google+'>
<svg class='svg-icon-24 touch-icon sharing-googlePlus'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_googlePlus_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Google+</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=email' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class='post-body entry-content float-container' id='post-body-4951045537399458814'>
<div class="separator" style="clear: both; text-align: center;">
<a href="https://2.bp.blogspot.com/-I51DYVrgIZ0/WpS3goSkwEI/AAAAAAAAGPA/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL/s1600/Dolphin-fan-sad.jpg" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="333" data-original-width="589" src="https://2.bp.blogspot.com/-I51DYVrgIZ0/WpS3goSkwEI/AAAAAAAAGPA/FRaJfFG9Ri44pDdpsqgXXJYrfAcNzf2RgCEwYBhgL/s1600/Dolphin-fan-sad.jpg" /></a></div>
<br />
<div dir="ltr" style="line-height: 1.295; margin-bottom: 8pt; margin-top: 0pt;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">Let me start this off by asking
you, the reader a few questions &#8211; how many times now has the Dolphins been
crowned winners of the offseason by making that &#8220;big splash&#8221; free agent signing
(WR Mike Wallace, DT Ndamukong Suh, and even QB Jay Cutler) Or making that big
offseason trade (CB Byron Maxwell and LB Kiko Alonso?) Or how about making a
big trade up in the draft (with the Raiders in 2013 for DE Dion Jordan?) And
now answer this, how many times has that paid off? How many times has been
stupidly aggressive paid off for our Miami Dolphins? Not one time and no, two
one and done playoff appearances in between 8 years doesn&#8217;t count. </span><br />
<br />
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">I&#8217;ve seen plenty of Dolfans on
the Twitterverse and on the <a href="http://dolphinstalk.com/">DolphinsTalk.com</a> comments section state they want
Miami to release Suh, Tannehill, and Mike Pouncey (easier said than done) and
then make the &#8220;big free agent splash&#8221; by signing Kirk Cousins and following up
with trading up in the draft and selecting one of the top quarterbacks, talk
about being stupidly aggressive. Let&#8217;s be honest, the people who want this, are
the same people who want Mike Tannenbaum fired but would praise him if he made
such a move - only to demand he&#8217;d be fired again in three years&#8217; time when
these moves backfired as they usually do.&nbsp;&nbsp;</span></div>
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;"><br /></span></div>
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">It&#8217;s time for the Miami
Dolphins fans and their front office, no matter who&#8217;s running it, to stop being
stupidly aggressive and start being smart. </span></div>
<br />
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">Stop throwing money away on
&#8220;big name&#8221; free agents and spread your cap around on mid-tier free agents &#8211;
Like instead throwing big money at Kirk Cousins, who could never get the job
done in Washington, Miami should turn around and sign mid-tier free agent
quarterback Josh McCown. McCown proved last season to be a more than reliable
starter with the Jets and would be an upgrade over Matt Moore as Tannehill&#8217;s
backup and wouldn&#8217;t stop Miami from taking a quarterback at any point in the
draft. If Tannehill goes down again, the Dolphins season wouldn&#8217;t be
jeopardized with McCown under center. McCown finished the season with 2,926 yards,
18 touchdowns, and 9 interceptions with a quarterback rating of 92.5.&nbsp;</span></div>
</div>
<div class="separator" style="clear: both; text-align: center;">
<a href="https://1.bp.blogspot.com/-C93TE2KWlQ8/WpS8ryCXtUI/AAAAAAAAGPI/z3LSBxO-YSUUcjYoZAWFTWD_Z3tVWVOnQCLcBGAs/s1600/McCown_StartingQB-story.jpg" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="350" data-original-width="700" height="200" src="https://1.bp.blogspot.com/-C93TE2KWlQ8/WpS8ryCXtUI/AAAAAAAAGPI/z3LSBxO-YSUUcjYoZAWFTWD_Z3tVWVOnQCLcBGAs/s400/McCown_StartingQB-story.jpg" width="400" /></a></div>
<div dir="ltr" style="line-height: 1.295; margin-bottom: 8pt; margin-top: 0pt;">
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">Another cheap option Miami
could go with is trading for Denver Broncos quarterback Trevor Siemian who
would only cost $1.9 million against the cap. Siemian would be another upgrade to
Moore backing up Tannehill and like Chad Pennington, Siemian is a game manager
who won&#8217;t cost you a game and or the season if Tannehill were to go down with
another injury. &nbsp;</span></div>
<br />
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">Build through the draft and
stop getting rid of your own &#8220;home grown&#8221; talents like Jarvis Landry (sooner or
later), Jay Ajayi, Olivier Vernon, Lamar Miller, Charles Clay, Sean Smith, and
Vontae Davis (you get the picture.)</span></div>
<br />
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">And then there&#8217;s this&#8230; Trade
down! Not up in the draft&#8230; gain more picks, not less. The Dolphins do not have
the luxury of cap space or a talented roster to be giving up players or picks
to be moving up in the draft for one player who may end in being a bust in
three years&#8217; time&#8230; we did that already with Dion Jordan. Now credit, Miami
didn&#8217;t give up much of anything that year to move up, only swapping their
first-round pick and giving up their second rounder as well &#8211; so I wouldn&#8217;t
mind that, if we had an extra second rounder to give but let&#8217;s stop living in
fantasy land and start living in reality. </span></div>
<br />
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">The Dolphins need to start
being smart and look at the successful teams of last season - like the Vikings,
Jaguars, Eagles, and even those damn Patriots. Sign mid-tier free agents, let
the draft fall to you and draft the best player available or trade down and
gain more picks to fill the roster with quality talent. This is the only way
that the Dolphins will ever get to the point of consistently winning football
games soon. No more wasting money, no more splashes and most of all no more
being aggressively stupid. </span></div>
<br />
<div style="line-height: 15.55pt; margin-bottom: .0001pt; margin: 0in;">
<span style="color: black; font-family: &quot;Georgia&quot;,serif; margin: 0px;">Follow me on Twitter at <a href="https://twitter.com/BobbyFinsTalk" target="_blank"><span style="color: blue;">@BobbyFinstalk</span></a>
for News, Rumors, and Opinions on everything Miami Dolphins!</span></div>
</div>
<div>
<span style="font-family: &quot;calibri&quot;; font-size: 12pt; vertical-align: baseline; white-space: pre-wrap;"><b></b><i></i><u></u><sub></sub><sup></sup><strike></strike><br /></span></div>
</div>
<div class='post-footer container'>
<div class='post-footer-line post-footer-line-1'>
</div>
<div class='post-footer-line post-footer-line-2'>
</div>
<div class='post-footer-line post-footer-line-3'>
</div>
<div class='post-share-buttons post-share-buttons-bottom'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-byline-4951045537399458814' class='sharing' data-title='The Case Against the Dolphins being Aggressively Stupid in Free Agency and the Draft'>
<button aria-controls='sharing-popup-Blog1-byline-4951045537399458814' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-4951045537399458814' role='button'>
<div class='flat-icon-button ripple'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_share_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-4951045537399458814' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=facebook' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=twitter' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=pinterest' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Share to Google+' class='sharing-platform-button sharing-element-googlePlus' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=googleplus' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to Google+'>
<svg class='svg-icon-24 touch-icon sharing-googlePlus'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_googlePlus_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Google+</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=4951045537399458814&target=email' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='http://www.dolphinstalk.com/2018/02/the-case-against-dolphins-being.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<section class='comments embed' data-num-comments='0' id='comments'>
<a name='comments'></a>
<h3 class='title'>Comments</h3>
<div id='Blog1_comments-block-wrapper'>
</div>
<div class='footer'>
<div class='comment-form'>
<a name='comment-form'></a>
<h4 id='comment-post-message'>Post a Comment</h4>
<a href='https://www.blogger.com/comment-iframe.g?blogID=7717974526047248338&postID=4951045537399458814&skin=emporio' id='comment-editor-src'></a>
<iframe allowtransparency='allowtransparency' class='blogger-iframe-colorize blogger-comment-from-post' frameborder='0' height='90px' id='comment-editor' name='comment-editor' src='' width='100%'></iframe>
<script src='https://www.blogger.com/static/v1/jsbin/2244480862-comment_from_post_iframe.js' type='text/javascript'></script>
<script type='text/javascript'>
      BLOG_CMT_createIframe('https://www.blogger.com/rpc_relay.html');
    </script>
</div>
</div>
</section>
</article>
</div>
</div></div>
</main>
<div class='vertical-ad-container no-items section' id='ads' name='Ads'>
</div>
<aside class='sidebar-container container' role='complementary'>
<div class='section' id='sidebar_item' name='Sidebar (Item Page)'><div class='widget PopularPosts' data-version='2' id='PopularPosts1'>
<h3 class='title'>
Popular Posts
</h3>
<div class='widget-content'>
<div role='feed'>
<article class='post' role='article'>
<div class='item-thumbnail'>
<a href='http://www.dolphinstalk.com/2018/02/audio-boomer-esiason-thinks-miami-might.html'>
<img alt='Image' src='https://2.bp.blogspot.com/-0n_geNwutP4/WpFkBgxOd3I/AAAAAAAACxc/_0zAKN3Zzx80yG23-_Poi_h-4yxtB5X8wCLcBGAs/s320/Boomer3.jpg' srcset='https://2.bp.blogspot.com/-0n_geNwutP4/WpFkBgxOd3I/AAAAAAAACxc/_0zAKN3Zzx80yG23-_Poi_h-4yxtB5X8wCLcBGAs/w280/Boomer3.jpg 280w, https://2.bp.blogspot.com/-0n_geNwutP4/WpFkBgxOd3I/AAAAAAAACxc/_0zAKN3Zzx80yG23-_Poi_h-4yxtB5X8wCLcBGAs/w560/Boomer3.jpg 560w, https://2.bp.blogspot.com/-0n_geNwutP4/WpFkBgxOd3I/AAAAAAAACxc/_0zAKN3Zzx80yG23-_Poi_h-4yxtB5X8wCLcBGAs/w840/Boomer3.jpg 840w, https://2.bp.blogspot.com/-0n_geNwutP4/WpFkBgxOd3I/AAAAAAAACxc/_0zAKN3Zzx80yG23-_Poi_h-4yxtB5X8wCLcBGAs/w1120/Boomer3.jpg 1120w, https://2.bp.blogspot.com/-0n_geNwutP4/WpFkBgxOd3I/AAAAAAAACxc/_0zAKN3Zzx80yG23-_Poi_h-4yxtB5X8wCLcBGAs/w1400/Boomer3.jpg 1400w'/>
</a>
</div>
<h3 class='post-title'><a href='http://www.dolphinstalk.com/2018/02/audio-boomer-esiason-thinks-miami-might.html'>AUDIO: Boomer Esiason Thinks Miami Might Make a Play for Kirk Cousins</a></h3>
<div class='item-content'>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
On his highly rated WFAN Morning Radio show this past Friday, Feb 23rd Boomer Esiason stated he believes that Mike Tannenbaum and the Miami Dolphins are currently moving money around to make a big splash move and sign Kirk Cousins. He believes Tannenbaum&#39;s history of always wanting to make a &quot;splash&quot; move, as well as Florida&#39;s no state income tax, and the Dolphins desperate search to upgrade the QB position makes the Dolphins a Sleeper team in the Kirk Cousins Sweepstakes and the team to keep an eye on. <i><b>Listen to the audio below.</b></i><br><i></i><b></b><br>
</div>
<a class='snippet-fade r-snippet-fade hidden' href='http://www.dolphinstalk.com/2018/02/audio-boomer-esiason-thinks-miami-might.html'></a>
</div>
</div>
</article>
<article class='post' role='article'>
<div class='item-thumbnail'>
<a href='http://www.dolphinstalk.com/2018/02/video-jeff-darlington-of-espn-believes.html'>
<img alt='Image' src='https://lh6.googleusercontent.com/proxy/grLNUwr8-NDAYuskbhwu0Z31wVu6gCjGI6TKm0bDC-LoBRqOxzeWBJk0-Xczt3l47AXa75pKMfd9ywjjnfq2KdOpVJo' srcset='https://lh6.googleusercontent.com/proxy/grLNUwr8-NDAYuskbhwu0Z31wVu6gCjGI6TKm0bDC-LoBRqOxzeWBJk0-Xczt3l47AXa75pKMfd9ywjjnfq2KdOpVJo=w280 280w, https://lh6.googleusercontent.com/proxy/grLNUwr8-NDAYuskbhwu0Z31wVu6gCjGI6TKm0bDC-LoBRqOxzeWBJk0-Xczt3l47AXa75pKMfd9ywjjnfq2KdOpVJo=w560 560w, https://lh6.googleusercontent.com/proxy/grLNUwr8-NDAYuskbhwu0Z31wVu6gCjGI6TKm0bDC-LoBRqOxzeWBJk0-Xczt3l47AXa75pKMfd9ywjjnfq2KdOpVJo=w840 840w, https://lh6.googleusercontent.com/proxy/grLNUwr8-NDAYuskbhwu0Z31wVu6gCjGI6TKm0bDC-LoBRqOxzeWBJk0-Xczt3l47AXa75pKMfd9ywjjnfq2KdOpVJo=w1120 1120w, https://lh6.googleusercontent.com/proxy/grLNUwr8-NDAYuskbhwu0Z31wVu6gCjGI6TKm0bDC-LoBRqOxzeWBJk0-Xczt3l47AXa75pKMfd9ywjjnfq2KdOpVJo=w1400 1400w'/>
</a>
</div>
<h3 class='post-title'><a href='http://www.dolphinstalk.com/2018/02/video-jeff-darlington-of-espn-believes.html'>VIDEO: Jeff Darlington of ESPN Believes Landry Will Be in a Dolphins Uniform in 2018</a></h3>
<div class='item-content'>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
ESPN Reporter Jeff Darlington <i>(who used to cover the Dolphins when he worked for the Miami Herald and who is very tied in with the organization) </i>stated that he believes the Dolphins and Jarvis Landry are close to a deal and Miami still may use the Franchise or Transition tag on him to hold onto him for 2018. The scenario that is least likely according to Darlington is Landry walks and is on another teams roster in 2018. Watch below....<br><br><br><br><b>Follow us on Twitter&#160;<a href="https://twitter.com/DolphinsTalk">@DolphinsTalk</a></b> <b><br></b> <b><br></b> <b>Be sure to SUBSCRIBE for free to the DolphinsTalk.com Podcast (<a href="https://itunes.apple.com/us/podcast/dolphinstalk-com-daily/id1289046573?mt=2">CLICK HERE</a>) we have on guests like Armando Salguero, Phil Simms, Jarvis Landry, Richmond Webb, OJ McDuffie, Sam Madison, Troy Stradford, and Ronnie Brown just to name a few.</b>
</div>
<a class='snippet-fade r-snippet-fade hidden' href='http://www.dolphinstalk.com/2018/02/video-jeff-darlington-of-espn-believes.html'></a>
</div>
</div>
</article>
<article class='post' role='article'>
<div class='item-thumbnail'>
<a href='http://www.dolphinstalk.com/2018/02/dt-daily-for-mon-feb-19th-dolphins_19.html'>
<img alt='Image' src='https://4.bp.blogspot.com/-YHfmEf6QdL0/WooqPqmpM3I/AAAAAAAACuk/At7J4jyrTygVYWqa1Zb3d1ruYCN8EO6CACEwYBhgL/s640/Landry43.jpg' srcset='https://4.bp.blogspot.com/-YHfmEf6QdL0/WooqPqmpM3I/AAAAAAAACuk/At7J4jyrTygVYWqa1Zb3d1ruYCN8EO6CACEwYBhgL/w280/Landry43.jpg 280w, https://4.bp.blogspot.com/-YHfmEf6QdL0/WooqPqmpM3I/AAAAAAAACuk/At7J4jyrTygVYWqa1Zb3d1ruYCN8EO6CACEwYBhgL/w560/Landry43.jpg 560w, https://4.bp.blogspot.com/-YHfmEf6QdL0/WooqPqmpM3I/AAAAAAAACuk/At7J4jyrTygVYWqa1Zb3d1ruYCN8EO6CACEwYBhgL/w840/Landry43.jpg 840w, https://4.bp.blogspot.com/-YHfmEf6QdL0/WooqPqmpM3I/AAAAAAAACuk/At7J4jyrTygVYWqa1Zb3d1ruYCN8EO6CACEwYBhgL/w1120/Landry43.jpg 1120w, https://4.bp.blogspot.com/-YHfmEf6QdL0/WooqPqmpM3I/AAAAAAAACuk/At7J4jyrTygVYWqa1Zb3d1ruYCN8EO6CACEwYBhgL/w1400/Landry43.jpg 1400w'/>
</a>
</div>
<h3 class='post-title'><a href='http://www.dolphinstalk.com/2018/02/dt-daily-for-mon-feb-19th-dolphins_19.html'>DT Daily for Mon, Feb 19th: Dolphins Uniforms Changing & ESPN report on Landry Most Likely Staying in Miami</a></h3>
<div class='item-content'>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
On today&#39;s show we talk about the ESPN report by Jeff Darlington over the weekend on how it is looking more likely that Jarvis Landry will be in a Miami Dolphins uniform in 2018. We talk about what Darlington said and break it down. We also talk about the announcement that the Miami Dolphins will be making changes to their uniforms for the upcoming 2018 season. What may they be and what could the Dolphins do to improve and tweak the current uniforms. To close the show we talk with one of the newest writers to DolphinsTalk.com Bobby Melendez and his latest article which is a Pre-Free Agency Miami Dolphins only Mock Draft. We get Bobby&#39;s thoughts on his article and why he had Miami selecting certain guys.<b></b><i></i><br><b></b><i></i><br><b style="font-weight: 700;"><i>(Click One of the Links Below to Listen )</i></b> <br><b style="font-weight: 700;">Soundcloud:<a href="https://soundcloud.com/dolphinstalk/dt-daily-for-mon-feb-19th-dolphins-uniforms-news-espn-report-on-landry">CLICK HERE</a></b><br><br style="background-color: white; color: #1f1f1f; font-style: normal; font-weight: 400; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><b style="background-color: white; color: #1f1f1f; font-style: normal; font-weight: 700; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;">iTunes:<a href="https://itunes.apple.com/us/podcast/dolphinstalk-com-daily/id1289046573?mt=2">CLICK HERE</a></b> <br> <b style="font-weight: 700;">Stitcher:
</div>
<a class='snippet-fade r-snippet-fade hidden' href='http://www.dolphinstalk.com/2018/02/dt-daily-for-mon-feb-19th-dolphins_19.html'></a>
</div>
</div>
</article>
</div>
</div>
</div></div>
</aside>
<!-- close sidebar-container -->
</div>
<!-- close centered-bottom -->
</div>
<!-- close centered -->
</div>
<!-- close page_body -->
<footer class='footer section' id='footer' name='Footer'><div class='widget Attribution' data-version='2' id='Attribution1'>
<div class='widget-content'>
<div class='blogger'>
<a href='https://www.blogger.com'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_post_blogger_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
Powered by Blogger
</a>
</div>
</div>
</div></footer>
</div>
<script type="text/javascript" src="https://resources.blogblog.com/blogblog/data/res/159603186-vegeclub_compiled.js" async="true"></script>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/2227587253-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>