<!DOCTYPE html>
<html dir='ltr'>
<head>
<meta content='width=device-width, initial-scale=1' name='viewport'/>
<title>DT Daily for Wed, April 25th: DolphinsTalk.com 2018 Dolphins Draft Preview</title>
<meta content='text/html; charset=UTF-8' http-equiv='Content-Type'/>
<!-- Chrome, Firefox OS and Opera -->
<meta content='#212121' name='theme-color'/>
<!-- Windows Phone -->
<meta content='#212121' name='msapplication-navbutton-color'/>
<meta content='blogger' name='generator'/>
<link href='http://www.dolphinstalk.com/favicon.ico' rel='icon' type='image/x-icon'/>
<link href='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' rel='canonical'/>
<link rel="alternate" type="application/atom+xml" title="DolphinsTalk.com - Atom" href="http://www.dolphinstalk.com/feeds/posts/default" />
<link rel="alternate" type="application/rss+xml" title="DolphinsTalk.com - RSS" href="http://www.dolphinstalk.com/feeds/posts/default?alt=rss" />
<link rel="service.post" type="application/atom+xml" title="DolphinsTalk.com - Atom" href="https://www.blogger.com/feeds/7717974526047248338/posts/default" />

<link rel="alternate" type="application/atom+xml" title="DolphinsTalk.com - Atom" href="http://www.dolphinstalk.com/feeds/3360067941015196587/comments/default" />
<!--Can't find substitution for tag [blog.ieCssRetrofitLinks]-->
<link href='https://2.bp.blogspot.com/-8Gu8hXl6INc/WuEeUi2dSYI/AAAAAAAADPM/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs/s400/DT.jpg' rel='image_src'/>
<meta content='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' property='og:url'/>
<meta content='DT Daily for Wed, April 25th: DolphinsTalk.com 2018 Dolphins Draft Preview' property='og:title'/>
<meta content='On today&#39;s show Mike and Tom do a total breakdown of the upcoming 2018 Miami Dolphins draft. We talk about who we think the Dolphins should ...' property='og:description'/>
<meta content='https://2.bp.blogspot.com/-8Gu8hXl6INc/WuEeUi2dSYI/AAAAAAAADPM/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs/w1200-h630-p-k-no-nu/DT.jpg' property='og:image'/>
<!--[if IE]> <script> (function() { var html5 = ("abbr,article,aside,audio,canvas,datalist,details," + "figure,footer,header,hgroup,mark,menu,meter,nav,output," + "progress,section,time,video").split(','); for (var i = 0; i < html5.length; i++) { document.createElement(html5[i]); } try { document.execCommand('BackgroundImageCache', false, true); } catch(e) {} })(); </script> <![endif]-->
<style type='text/css'>@font-face{font-family:'Ubuntu';font-style:normal;font-weight:400;src:local('Ubuntu Regular'),local('Ubuntu-Regular'),url(//fonts.gstatic.com/s/ubuntu/v11/4iCs6KVjbNBYlgoKfw7z.ttf)format('truetype');}@font-face{font-family:'Ubuntu';font-style:normal;font-weight:500;src:local('Ubuntu Medium'),local('Ubuntu-Medium'),url(//fonts.gstatic.com/s/ubuntu/v11/4iCv6KVjbNBYlgoCjC3jsGyI.ttf)format('truetype');}@font-face{font-family:'Merriweather';font-style:normal;font-weight:400;src:local('Merriweather Regular'),local('Merriweather-Regular'),url(//fonts.gstatic.com/s/merriweather/v19/u-440qyriQwlOrhSvowK_l5-fCZJ.ttf)format('truetype');}@font-face{font-family:'Merriweather';font-style:italic;font-weight:300;src:local('Merriweather Light Italic'),local('Merriweather-LightItalic'),url(//fonts.gstatic.com/s/merriweather/v19/u-4l0qyriQwlOrhSvowK_l5-eR7lXff4jvk.ttf)format('truetype');}@font-face{font-family:'Ubuntu';font-style:normal;font-weight:700;src:local('Ubuntu Bold'),local('Ubuntu-Bold'),url(//fonts.gstatic.com/s/ubuntu/v11/4iCv6KVjbNBYlgoCxCvjsGyI.ttf)format('truetype');}@font-face{font-family:'Merriweather';font-style:italic;font-weight:400;src:local('Merriweather Italic'),local('Merriweather-Italic'),url(//fonts.gstatic.com/s/merriweather/v19/u-4m0qyriQwlOrhSvowK_l5-eRZOf-c.ttf)format('truetype');}</style>
<style id='page-skin-1' type='text/css'>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</style>
<style id='template-skin-1' type='text/css'><!--
body#layout .hidden,
body#layout .invisible {
display: inherit;
}
body#layout .centered-bottom {
position: relative;
}
body#layout .section.featured-post,
body#layout .section.main,
body#layout .section.vertical-ad-container {
float: left;
width: 55%;
}
body#layout .sidebar-container {
display: inline-block;
width: 39%;
}
body#layout .centered-bottom:after {
clear: both;
content: "";
display: table;
}
body#layout .hamburger-menu,
body#layout .search {
display: none;
}
--></style>
<script async='async' src='https://www.gstatic.com/external_hosted/clipboardjs/clipboard.min.js'></script>
<link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=7717974526047248338&amp;zx=ab490693-9050-46fd-841f-16c9e825b107' media='none' onload='if(media!=&#39;all&#39;)media=&#39;all&#39;' rel='stylesheet'/><noscript><link href='https://www.blogger.com/dyn-css/authorization.css?targetBlogID=7717974526047248338&amp;zx=ab490693-9050-46fd-841f-16c9e825b107' rel='stylesheet'/></noscript>
</head>
<body class='item-view version-1-3-0 variant-vegeclub_darkaqua'>
<a class='skip-navigation' href='#main' tabindex='0'>
Skip to main content
</a>
<div class='page'>
<div class='page_body'>
<style>
    .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-8Gu8hXl6INc\/WuEeUi2dSYI\/AAAAAAAADPM\/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs\/s400\/DT.jpg);}
    
@media (max-width: 200px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-8Gu8hXl6INc\/WuEeUi2dSYI\/AAAAAAAADPM\/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs\/w200\/DT.jpg);}}
@media (max-width: 400px) and (min-width: 201px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-8Gu8hXl6INc\/WuEeUi2dSYI\/AAAAAAAADPM\/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs\/w400\/DT.jpg);}}
@media (max-width: 800px) and (min-width: 401px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-8Gu8hXl6INc\/WuEeUi2dSYI\/AAAAAAAADPM\/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs\/w800\/DT.jpg);}}
@media (max-width: 1200px) and (min-width: 801px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-8Gu8hXl6INc\/WuEeUi2dSYI\/AAAAAAAADPM\/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs\/w1200\/DT.jpg);}}
/* Last tag covers anything over one higher than the previous max-size cap. */
@media (min-width: 1201px) { .bg-photo {background-image:url(https\:\/\/2.bp.blogspot.com\/-8Gu8hXl6INc\/WuEeUi2dSYI\/AAAAAAAADPM\/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs\/w1600\/DT.jpg);}}
  </style>
<div class='bg-photo-container'>
<div class='bg-photo'></div>
</div>
<div class='centered'>
<header class='centered-top-container sticky' role='banner'>
<div class='centered-top'>
<a class='return_link' href='http://www.dolphinstalk.com/'>
<svg class='svg-icon-24 touch-icon back-button rtl-reversible-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_arrow_back_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</a>
<div class='blog-name'>
<div class='section' id='header' name='Header'><div class='widget Header' data-version='2' id='Header1'>
<div class='header-widget'>
<a class='header-image-wrapper' href='http://www.dolphinstalk.com/'>
<img alt='DolphinsTalk.com' data-original-height='346' data-original-width='1600' src='http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/s1600/1111111.jpg' srcset='http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w120/1111111.jpg 120w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w240/1111111.jpg 240w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w480/1111111.jpg 480w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w640/1111111.jpg 640w, http://2.bp.blogspot.com/-nves3z4SbEI/WnfbvKGoElI/AAAAAAAACnw/GOmcmA9SSxYccCaG6Ua_qxUWPl6LAH5MACK4BGAYYCw/w800/1111111.jpg 800w'/>
</a>
<div class='replaced'>
<h1>
<a href='http://www.dolphinstalk.com/'>
DolphinsTalk.com
</a>
</h1>
</div>
</div>
</div></div>
</div>
<div class='search'>
<button aria-label='Search' class='search-expand touch-icon-button'>
<div class='search-expand-text'>Search</div>
<svg class='svg-icon-24 touch-icon search-expand-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</button>
<div class='section' id='search_top' name='Search (Top)'><div class='widget BlogSearch' data-version='2' id='BlogSearch1'>
<h3 class='title'>
Search This Blog
</h3>
<div class='widget-content' role='search'>
<form action='http://www.dolphinstalk.com/search' target='_top'>
<div class='search-input'>
<input aria-label='Search this blog' autocomplete='off' name='q' placeholder='Search this blog' value=''/>
</div>
<label class='search-submit-container'>
<input type='submit'/>
<svg class='svg-icon-24 touch-icon search-icon'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_search_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</label>
</form>
</div>
</div></div>
</div>
</div>
</header>
<div class='centered-bottom'>
<main class='main-container' id='main' role='main' tabindex='-1'>
<div class='featured-post section' id='featured_post' name='Featured Post'>
</div>
<div class='main section' id='page_body' name='Page Body'><div class='widget Blog' data-version='2' id='Blog1'>
<div class='blog-posts hfeed container'>
<article class='post-outer-container'>
<div class='post-outer'>
<div class='post-wrapper not-hero post-3360067941015196587 image'>
<div class='snippet-thumbnail-container'>
<div class='snippet-thumbnail post-thumb-3360067941015196587'></div>
</div>
<div class='slide'>
<div class='post'>
<script type='application/ld+json'>{
  "@context": "http://schema.org",
  "@type": "BlogPosting",
  "mainEntityOfPage": {
    "@type": "WebPage",
    "@id": "http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html"
  },
  "headline": "DT Daily for Wed, April 25th: DolphinsTalk.com 2018 Dolphins Draft Preview","description": "On today\u0026#39;s show Mike and Tom do a total breakdown of the upcoming 2018 Miami Dolphins draft. We talk about who we think the Dolphins should be lo&#8230;","datePublished": "2018-04-25T20:35:00-04:00",
  "dateModified": "2018-04-25T20:35:23-04:00","image": {
    "@type": "ImageObject","url": "https://2.bp.blogspot.com/-8Gu8hXl6INc/WuEeUi2dSYI/AAAAAAAADPM/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs/w1200-h630-p-k-no-nu/DT.jpg",
    "height": 630,
    "width": 1200},"publisher": {
    "@type": "Organization",
    "name": "Blogger",
    "logo": {
      "@type": "ImageObject",
      "url": "https://lh3.googleusercontent.com/ULB6iBuCeTVvSjjjU1A-O8e9ZpVba6uvyhtiWRti_rBAs9yMYOFBujxriJRZ-A=h60",
      "width": 206,
      "height": 60
    }
  },"author": {
    "@type": "Person",
    "name": "Mike Oliva"
  }
}</script>
<div class='post-title-container'>
<a name='3360067941015196587'></a>
<h3 class='post-title entry-title'>
DT Daily for Wed, April 25th: DolphinsTalk.com 2018 Dolphins Draft Preview
</h3>
</div>
<div class='post-header'>
<div class='post-header-line-1'>
<span class='byline post-author vcard'>
<span class='post-author-label'>
Posted by
</span>
<span class='fn'>
<meta content='https://www.blogger.com/profile/13681684726004208543'/>
<a class='g-profile' href='https://www.blogger.com/profile/13681684726004208543' rel='author' title='author profile'>
<span>Mike Oliva</span>
</a>
</span>
</span>
<span class='byline post-timestamp'>
on
<meta content='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html'/>
<a class='timestamp-link' href='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' rel='bookmark' title='permanent link'>
<time class='published' datetime='2018-04-25T20:35:00-04:00' title='2018-04-25T20:35:00-04:00'>
April 25, 2018
</time>
</a>
</span>
</div>
</div>
<div class='post-share-buttons post-share-buttons-top'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-byline-3360067941015196587' class='sharing' data-title='DT Daily for Wed, April 25th: DolphinsTalk.com 2018 Dolphins Draft Preview'>
<button aria-controls='sharing-popup-Blog1-byline-3360067941015196587' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-3360067941015196587' role='button'>
<div class='flat-icon-button ripple'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_share_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-3360067941015196587' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=facebook' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=twitter' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=pinterest' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Share to Google+' class='sharing-platform-button sharing-element-googlePlus' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=googleplus' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Google+'>
<svg class='svg-icon-24 touch-icon sharing-googlePlus'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_googlePlus_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Google+</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=email' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
</div>
<div class='post-body entry-content float-container' id='post-body-3360067941015196587'>
On today's show Mike and Tom do a total breakdown of the upcoming 2018 Miami Dolphins draft. We talk about who we think the Dolphins should be looking at in this draft and give some strong opinions as to why we need to target certain players and certain positions this upcoming weekend during the draft.<br />
<div style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-size: 14px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;">
<div style="background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-style: normal; font-variant: normal; font-weight: 400; letter-spacing: normal; margin: 0px; text-align: center; text-decoration: none; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;">
<div style="margin: 0px;">
<span style="font-family: georgia;"><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="background-color: white;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="color: #b08500; font-family: georgia;"><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: blue;"><b style="font-weight: 700;"><i><span style="font-size: small;">(Click One of the Links Below to Listen )</span></i></b></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="font-family: georgia;"><br /></span></span></span></div>
</div>
<div style="background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-style: normal; font-variant: normal; font-weight: 400; letter-spacing: normal; text-align: left; text-decoration: none; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;">
<div style="margin: 0px;">
<div style="margin: 0px;">
<span style="background-color: white;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="font-family: georgia;"><span style="font-family: georgia;"></span><span style="font-family: georgia;"><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"></span><span style="color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"></span><span style="background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: #1f1f1f; font-family: quot; letter-spacing: normal; text-align: center; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: #333333; display: inline; float: none; letter-spacing: normal; text-align: center; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: #1f1f1f; font-family: quot; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: #1f1f1f; font-family: quot; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: #1f1f1f; font-family: quot; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="color: #333333; display: inline; float: none; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="color: #333333; display: inline; float: none; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="color: #333333; display: inline; float: none; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="color: #333333; display: inline; float: none; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white;"><span style="background-color: white; color: #1f1f1f; font-family: quot; font-style: normal; font-weight: 400; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="font-family: verdana, sans-serif;"><span style="font-size: large;"><span style="background-color: white; color: #1f1f1f; font-family: verdana, sans-serif; font-style: normal; font-weight: 400; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><b style="font-weight: 700;"><span style="color: #1f1f1f;">Soundcloud:<span class="Apple-converted-space">&nbsp;</span></span><a href="https://soundcloud.com/dolphinstalk/dt-daily-425-dolphinstalkcom-2018-dolphins-draft-preview" style="background: none 0% 0% / auto repeat scroll padding-box border-box transparent; color: #ff5722; font-style: normal; text-decoration: none;">CLICK HERE</a><span style="background-color: white; color: #1f1f1f; display: inline; float: none; font-family: verdana, sans-serif; font-style: normal; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"></span></b><span style="background-color: white; color: #1f1f1f; font-family: verdana, sans-serif; font-style: normal; font-weight: 400; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><br /></span></span><br style="background-color: white; color: #1f1f1f; font-style: normal; font-weight: 400; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;" /><span style="background-color: white; color: #1f1f1f; font-family: verdana, sans-serif; font-style: normal; font-weight: 400; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><span style="background-color: white; color: #1f1f1f; font-family: verdana, sans-serif; font-style: normal; font-weight: 400; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><b style="background-color: white; color: #1f1f1f; font-style: normal; font-weight: 700; letter-spacing: normal; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;">iTunes:<span class="Apple-converted-space">&nbsp;</span><a href="https://itunes.apple.com/us/podcast/dolphinstalk-com-daily/id1289046573?mt=2" style="background: none 0% 0% / auto repeat scroll padding-box border-box transparent; color: #ff5722; font-style: normal; text-decoration: none;">CLICK HERE</a></b></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></span></div>
</div>
</div>
<div style="background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-style: normal; font-variant: normal; font-weight: 400; letter-spacing: normal; text-align: left; text-decoration: none; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;">
<div style="margin: 0px;">
<div style="margin: 0px;">
<span style="font-size: large;"></span><br /></div>
</div>
</div>
<div style="background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-style: normal; font-variant: normal; font-weight: 400; letter-spacing: normal; text-align: left; text-decoration: none; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;">
<div style="margin: 0px;">
<div style="margin: 0px;">
<span style="font-size: large;"><b style="font-weight: 700;"><span style="font-family: verdana, sans-serif;">TuneIN:&nbsp;&nbsp;<a href="https://tunein.com/radio/DolphinsTalkcom-Daily-p1035413/" style="background: none 0% 0% / auto repeat scroll padding-box border-box transparent; color: #ff5722; font-style: normal; text-decoration: none;">CLICK HERE</a></span></b><br /><b style="font-weight: bold;"><span style="color: blue; font-family: verdana;"><i><br /></i></span></b><b style="font-weight: bold;"><i><span style="color: blue; font-family: verdana;">You can also find the show on</span><span style="font-family: verdana;">&nbsp;Stitcher, PodBean, and GooglePlay</span></i></b></span><b style="font-weight: bold;"><i><span style="font-family: verdana;"></span></i></b><b style="font-weight: bold;"><br /></b></div>
</div>
</div>
</div>
<span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"><span style="font-size: medium;"></span><span style="font-size: large;"></span><br /></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; display: inline; float: none; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; display: inline; float: none; font-family: georgia; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #333333; display: inline; float: none; font-family: interstate, &quot;lucida grande&quot;, &quot;lucida sans unicode&quot;, &quot;lucida sans&quot;, garuda, verdana, tahoma, sans-serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span><span style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; display: inline !important; float: none; font-family: Merriweather, Georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: start; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"></span>
<div style="-webkit-text-stroke-width: 0px; background-color: white; color: #1f1f1f; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: center; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;">
<b style="-webkit-text-stroke-width: 0px; background-color: transparent; color: #1f1f1f; font-style: normal; font-variant: normal; font-weight: 700; letter-spacing: normal; orphans: 2; text-align: center; text-decoration: none; text-indent: 0px; text-transform: none; white-space: normal; word-spacing: 0px;"><i><span style="font-size: medium;">Follow us on Twitter&nbsp;<a href="https://twitter.com/DolphinsTalk" style="background: none 0% 0% / auto repeat scroll padding-box border-box transparent; color: #ff5722; font-style: normal; text-decoration: none;">@DolphinsTalk&nbsp;</a></span></i></b></div>
<div class="separator" style="clear: both; text-align: center;">
<a href="https://2.bp.blogspot.com/-8Gu8hXl6INc/WuEeUi2dSYI/AAAAAAAADPM/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs/s1600/DT.jpg" imageanchor="1" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="512" data-original-width="512" height="400" src="https://2.bp.blogspot.com/-8Gu8hXl6INc/WuEeUi2dSYI/AAAAAAAADPM/Rev52l3Z1TQqdLMatltMJxYPbL4UsSZzgCLcBGAs/s400/DT.jpg" width="400" /></a></div>
<span style="-webkit-text-stroke-width: 0px; background-color: white; color: red; font-family: merriweather, georgia, serif; font-size: 16px; font-style: normal; font-variant-caps: normal; font-variant-ligatures: normal; font-weight: 400; letter-spacing: normal; orphans: 2; text-align: left; text-decoration-color: initial; text-decoration-style: initial; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;"><b style="font-weight: bold;"><i><span style="font-family: georgia;">Previous Guests on the DolphinsTalk.com Podcast are:</span></i></b></span><span style="-webkit-text-stroke-width: 0px; background-color: transparent; color: #1f1f1f; font-family: merriweather, georgia, serif; font-size: 16px; font-style: italic; font-variant: normal; font-weight: 700; letter-spacing: normal; orphans: 2; text-align: left; text-decoration: none; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;">&nbsp;Jarvis Landry, Michael Thomas, Phil Simms, Sam Madison, OJ McDuffie, Ronnie Brown, Richmond Webb, Armando Salguero, Troy Stradford, Jason Lieser, Marco Coleman, Mark Clayton, Todd Wade, Jay Fiedler, Orlando Alzugaray, Dave Hyde, Greg Likens, Tim Robbie, Shawn Wooden, Benjamin Allbright, and Kevin Donnalley.&nbsp;</span><span style="-webkit-text-stroke-width: 0px; background-color: transparent; color: red; font-family: merriweather, georgia, serif; font-size: 16px; font-style: italic; font-variant: normal; font-weight: 700; letter-spacing: normal; orphans: 2; text-align: left; text-decoration: none; text-indent: 0px; text-transform: none; white-space: normal; widows: 2; word-spacing: 0px;">BE SURE TO CHECK OUT OUR ARCHIVES TO LISTEN TO THOSE PREVIOUS GUESTS ON OUR PODCAST.</span><b></b><i></i><u></u><sub></sub><sup></sup><strike></strike>
</div>
<div class='post-footer container'>
<div class='post-footer-line post-footer-line-1'>
</div>
<div class='post-footer-line post-footer-line-2'>
</div>
<div class='post-footer-line post-footer-line-3'>
</div>
<div class='post-share-buttons post-share-buttons-bottom'>
<div class='byline post-share-buttons goog-inline-block'>
<div aria-owns='sharing-popup-Blog1-byline-3360067941015196587' class='sharing' data-title='DT Daily for Wed, April 25th: DolphinsTalk.com 2018 Dolphins Draft Preview'>
<button aria-controls='sharing-popup-Blog1-byline-3360067941015196587' aria-label='Share' class='sharing-button touch-icon-button' id='sharing-button-Blog1-byline-3360067941015196587' role='button'>
<div class='flat-icon-button ripple'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_share_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
</div>
</button>
<div class='share-buttons-container'>
<ul aria-hidden='true' aria-label='Share' class='share-buttons hidden' id='sharing-popup-Blog1-byline-3360067941015196587' role='menu'>
<li>
<span aria-label='Get link' class='sharing-platform-button sharing-element-link' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Get link'>
<svg class='svg-icon-24 touch-icon sharing-link'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_link_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Get link</span>
</span>
</li>
<li>
<span aria-label='Share to Facebook' class='sharing-platform-button sharing-element-facebook' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=facebook' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Facebook'>
<svg class='svg-icon-24 touch-icon sharing-facebook'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_facebook_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Facebook</span>
</span>
</li>
<li>
<span aria-label='Share to Twitter' class='sharing-platform-button sharing-element-twitter' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=twitter' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Twitter'>
<svg class='svg-icon-24 touch-icon sharing-twitter'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_twitter_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Twitter</span>
</span>
</li>
<li>
<span aria-label='Share to Pinterest' class='sharing-platform-button sharing-element-pinterest' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=pinterest' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Pinterest'>
<svg class='svg-icon-24 touch-icon sharing-pinterest'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_pinterest_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Pinterest</span>
</span>
</li>
<li>
<span aria-label='Share to Google+' class='sharing-platform-button sharing-element-googlePlus' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=googleplus' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to Google+'>
<svg class='svg-icon-24 touch-icon sharing-googlePlus'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_googlePlus_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Google+</span>
</span>
</li>
<li>
<span aria-label='Email' class='sharing-platform-button sharing-element-email' data-href='https://www.blogger.com/share-post.g?blogID=7717974526047248338&postID=3360067941015196587&target=email' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Email'>
<svg class='svg-icon-24 touch-icon sharing-email'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_24_email_dark' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Email</span>
</span>
</li>
<li aria-hidden='true' class='hidden'>
<span aria-label='Share to other apps' class='sharing-platform-button sharing-element-other' data-url='http://www.dolphinstalk.com/2018/04/dt-daily-for-wed-april-25th.html' role='menuitem' tabindex='-1' title='Share to other apps'>
<svg class='svg-icon-24 touch-icon sharing-sharingOther'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_more_horiz_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
<span class='platform-sharing-text'>Other Apps</span>
</span>
</li>
</ul>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<section class='comments embed' data-num-comments='0' id='comments'>
<a name='comments'></a>
<h3 class='title'>Comments</h3>
<div id='Blog1_comments-block-wrapper'>
</div>
<div class='footer'>
<div class='comment-form'>
<a name='comment-form'></a>
<h4 id='comment-post-message'>Post a Comment</h4>
<a href='https://www.blogger.com/comment-iframe.g?blogID=7717974526047248338&postID=3360067941015196587&skin=emporio' id='comment-editor-src'></a>
<iframe allowtransparency='allowtransparency' class='blogger-iframe-colorize blogger-comment-from-post' frameborder='0' height='90px' id='comment-editor' name='comment-editor' src='' width='100%'></iframe>
<script src='https://www.blogger.com/static/v1/jsbin/1565398628-comment_from_post_iframe.js' type='text/javascript'></script>
<script type='text/javascript'>
      BLOG_CMT_createIframe('https://www.blogger.com/rpc_relay.html');
    </script>
</div>
</div>
</section>
</article>
</div>
</div></div>
</main>
<div class='vertical-ad-container no-items section' id='ads' name='Ads'>
</div>
<aside class='sidebar-container container' role='complementary'>
<div class='section' id='sidebar_item' name='Sidebar (Item Page)'><div class='widget PopularPosts' data-version='2' id='PopularPosts1'>
<h3 class='title'>
Popular Posts
</h3>
<div class='widget-content'>
<div role='feed'>
<article class='post' role='article'>
<div class='item-thumbnail'>
<a href='http://www.dolphinstalk.com/2018/04/dolphins-workout-lamar-jackson-and-im.html'>
<img alt='Image' src='https://1.bp.blogspot.com/-GGcuM66C5nY/WsivtG0KkZI/AAAAAAAAAJI/7NzcIXvSHeggAh9JpJqMISYiJLD_11AiACLcBGAs/s320/Lamar-Jackson-likes-Twitter-post-featuring-himself-in-Miami-Dolphins-jersey.jpg' srcset='https://1.bp.blogspot.com/-GGcuM66C5nY/WsivtG0KkZI/AAAAAAAAAJI/7NzcIXvSHeggAh9JpJqMISYiJLD_11AiACLcBGAs/w280/Lamar-Jackson-likes-Twitter-post-featuring-himself-in-Miami-Dolphins-jersey.jpg 280w, https://1.bp.blogspot.com/-GGcuM66C5nY/WsivtG0KkZI/AAAAAAAAAJI/7NzcIXvSHeggAh9JpJqMISYiJLD_11AiACLcBGAs/w560/Lamar-Jackson-likes-Twitter-post-featuring-himself-in-Miami-Dolphins-jersey.jpg 560w, https://1.bp.blogspot.com/-GGcuM66C5nY/WsivtG0KkZI/AAAAAAAAAJI/7NzcIXvSHeggAh9JpJqMISYiJLD_11AiACLcBGAs/w840/Lamar-Jackson-likes-Twitter-post-featuring-himself-in-Miami-Dolphins-jersey.jpg 840w, https://1.bp.blogspot.com/-GGcuM66C5nY/WsivtG0KkZI/AAAAAAAAAJI/7NzcIXvSHeggAh9JpJqMISYiJLD_11AiACLcBGAs/w1120/Lamar-Jackson-likes-Twitter-post-featuring-himself-in-Miami-Dolphins-jersey.jpg 1120w, https://1.bp.blogspot.com/-GGcuM66C5nY/WsivtG0KkZI/AAAAAAAAAJI/7NzcIXvSHeggAh9JpJqMISYiJLD_11AiACLcBGAs/w1400/Lamar-Jackson-likes-Twitter-post-featuring-himself-in-Miami-Dolphins-jersey.jpg 1400w'/>
</a>
</div>
<h3 class='post-title'><a href='http://www.dolphinstalk.com/2018/04/dolphins-workout-lamar-jackson-and-im.html'>Dolphins Workout Lamar Jackson And I'm All for Them Drafting Him</a></h3>
<div class='item-content'>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
</div>
<a class='snippet-fade r-snippet-fade hidden' href='http://www.dolphinstalk.com/2018/04/dolphins-workout-lamar-jackson-and-im.html'></a>
</div>
</div>
</article>
<article class='post' role='article'>
<div class='item-thumbnail'>
<a href='http://www.dolphinstalk.com/2018/04/bobbys-dolphins-mock-draft-30-miami.html'>
<img alt='Image' src='https://2.bp.blogspot.com/-SwuzOPacH3o/WshXOJJIPiI/AAAAAAAAGSE/XYf8HRiRfTohdwqsmaC5LJrowNWnLib3wCLcBGAs/s400/Miami.PNG' srcset='https://2.bp.blogspot.com/-SwuzOPacH3o/WshXOJJIPiI/AAAAAAAAGSE/XYf8HRiRfTohdwqsmaC5LJrowNWnLib3wCLcBGAs/w280/Miami.PNG 280w, https://2.bp.blogspot.com/-SwuzOPacH3o/WshXOJJIPiI/AAAAAAAAGSE/XYf8HRiRfTohdwqsmaC5LJrowNWnLib3wCLcBGAs/w560/Miami.PNG 560w, https://2.bp.blogspot.com/-SwuzOPacH3o/WshXOJJIPiI/AAAAAAAAGSE/XYf8HRiRfTohdwqsmaC5LJrowNWnLib3wCLcBGAs/w840/Miami.PNG 840w, https://2.bp.blogspot.com/-SwuzOPacH3o/WshXOJJIPiI/AAAAAAAAGSE/XYf8HRiRfTohdwqsmaC5LJrowNWnLib3wCLcBGAs/w1120/Miami.PNG 1120w, https://2.bp.blogspot.com/-SwuzOPacH3o/WshXOJJIPiI/AAAAAAAAGSE/XYf8HRiRfTohdwqsmaC5LJrowNWnLib3wCLcBGAs/w1400/Miami.PNG 1400w'/>
</a>
</div>
<h3 class='post-title'><a href='http://www.dolphinstalk.com/2018/04/bobbys-dolphins-mock-draft-30-miami.html'>Bobby's Dolphins Mock Draft 3.0 (Miami trades down with Packers!)</a></h3>
<div class='item-content'>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
The Draft is 18 days away and everyone in league circles and on the Twitterverse has their opinion on what team should do what, for Dolphins Twitterverse it&#8217;s either: draft Mayfield, draft Derwin James, draft Minkah Fitzpatrick, draft Roquan Smith, draft Tremaine Edmunds, or how about Vita Vea? For me, it&#39;s let the draft fall to&#160;you and see who&#39;s available. Dolphins will have the luxury to either get a top-rated prospect who shouldn&#39;t&#160;be at their pick to begin with, or they could field offers to trade down and gain more picks (spoiler alert!). <br> Below is my third Dolphins team mock draft as well as my latest full round one Mock draft below that, Miami has a top safety fall to them at their pick but the Packers make them an offer that simply can&#8217;t refuse - with one trade down Miami gains 3 extra picks that balance&#39;s&#160;out their entire roster: <br> <i></i><br><i>(Of course as news break and trades occur, mock drafts like NCAA March Madness Brackets bust! So expect an updated version before Draf&#8230;
</div>
<a class='snippet-fade r-snippet-fade hidden' href='http://www.dolphinstalk.com/2018/04/bobbys-dolphins-mock-draft-30-miami.html'></a>
</div>
</div>
</article>
<article class='post' role='article'>
<div class='item-thumbnail'>
<a href='http://www.dolphinstalk.com/2018/04/dolphins-still-need-to-add-another.html'>
<img alt='Image' src='https://3.bp.blogspot.com/-ZiP-9JYSi1I/WtNstilq9nI/AAAAAAAADHc/4sjS5FSeccoPChljUS9fp8CnxUhFJ9yGQCLcBGAs/s640/Drake10.jpg' srcset='https://3.bp.blogspot.com/-ZiP-9JYSi1I/WtNstilq9nI/AAAAAAAADHc/4sjS5FSeccoPChljUS9fp8CnxUhFJ9yGQCLcBGAs/w280/Drake10.jpg 280w, https://3.bp.blogspot.com/-ZiP-9JYSi1I/WtNstilq9nI/AAAAAAAADHc/4sjS5FSeccoPChljUS9fp8CnxUhFJ9yGQCLcBGAs/w560/Drake10.jpg 560w, https://3.bp.blogspot.com/-ZiP-9JYSi1I/WtNstilq9nI/AAAAAAAADHc/4sjS5FSeccoPChljUS9fp8CnxUhFJ9yGQCLcBGAs/w840/Drake10.jpg 840w, https://3.bp.blogspot.com/-ZiP-9JYSi1I/WtNstilq9nI/AAAAAAAADHc/4sjS5FSeccoPChljUS9fp8CnxUhFJ9yGQCLcBGAs/w1120/Drake10.jpg 1120w, https://3.bp.blogspot.com/-ZiP-9JYSi1I/WtNstilq9nI/AAAAAAAADHc/4sjS5FSeccoPChljUS9fp8CnxUhFJ9yGQCLcBGAs/w1400/Drake10.jpg 1400w'/>
</a>
</div>
<h3 class='post-title'><a href='http://www.dolphinstalk.com/2018/04/dolphins-still-need-to-add-another.html'>Dolphins Still Need to Add another Running Back</a></h3>
<div class='item-content'>
<div class='popular-posts-snippet snippet-container r-snippet-container'>
<div class='snippet-item r-snippetized'>
With the way Kenyan Drake played at the end of the 2017 season
everyone is giddy with the thought of Drake being the #1 running back for the
Miami Dolphins for a full season heading into 2018. There are some red flags
though with the Dolphins running back position and adding another running back,
another quality running back, is key between now and the start of the 2018
season. <br>Yes, Kenyan Drake played like a man among boys the final five
games of the 2017 season and there is plenty of reason for optimism around him
heading into 2018. A couple of things to remember though like Drake has never
been the most durable player throughout his career. Whether at his time at Alabama
or his rookie year with the Dolphins, Drake has always been often injured and
dinged up missing time. To expect he can go from that type of player to a #1
lead running back overnight who will be expected to touch the ball some 15-20 times a game is asking a lot and expecting a lot out of someone
who has never been a&#8230;
</div>
<a class='snippet-fade r-snippet-fade hidden' href='http://www.dolphinstalk.com/2018/04/dolphins-still-need-to-add-another.html'></a>
</div>
</div>
</article>
</div>
</div>
</div></div>
</aside>
<!-- close sidebar-container -->
</div>
<!-- close centered-bottom -->
</div>
<!-- close centered -->
</div>
<!-- close page_body -->
<footer class='footer section' id='footer' name='Footer'><div class='widget Attribution' data-version='2' id='Attribution1'>
<div class='widget-content'>
<div class='blogger'>
<a href='https://www.blogger.com'>
<svg class='svg-icon-24'>
<use xlink:href='/responsive/sprite_v1_6.css.svg#ic_post_blogger_black_24dp' xmlns:xlink='http://www.w3.org/1999/xlink'></use>
</svg>
Powered by Blogger
</a>
</div>
</div>
</div></footer>
</div>
<script type="text/javascript" src="https://resources.blogblog.com/blogblog/data/res/1734437714-vegeclub_compiled.js" async="true"></script>

<script type="text/javascript" src="https://www.blogger.com/static/v1/widgets/1845596459-widgets.js"></script>
<script type='text/javascript'>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</script>
</body>
</html>